СУММЕСЛИ, СУММЕСЛИМН, СРЗНАЧЕСЛИ, СРЗНАЧЬЕСЛИМН со знаком «больше» или «меньше» значения в ячейке.

О том как правильно записать функции СРЗНАЧЕСЛИ, СРЗНАЧЬЕСЛИМН, СУММЕСЛИ, СУММЕСЛИМН с условиями (знаком) «больше», «меньше», «больше или равно», «меньше или равно» значения в ячейке таблицы Excel. 

Перечисленные в заголовке функции excel предназначены для выполнения действий с массивом данных при соблюдении тех или иных условий.

Самое простое их применение, когда нужно выполнить действия с простыми условиями «равно» или «содержит» описаны в статье:

Функции для определения среднего значения: «СРЗНАЧ», «СРЗНАЧА», «СРЗНАЧЕСЛИ», «СРЗНАЧЕСЛИМН».

Но, как правило, недостаточно. Гораздо сложнее сравнивать условие с содержимым заданной ячейки, не у всех это сразу получается.

Часто возникает необходимость сравнить значения с другими ячейками и выполнить суммирование или нахождение среднего числа с условиями «больше» или «меньше».

Например:
Есть таблица месячных объемов производства на 3-х заводах . И есть данные, в каком месяце было произведено переоснащение завода новым оборудованием. Нужно посчитать среднемесячный и суммарный объем производства на заводах после переоснащения.

Скрин Суммесли и Срзначесли
Скрин Суммесли и Срзначесли
Месяц: авг.19 сен.19 окт.19 ноя.19 дек.19 янв.20 фев.20
Название завода
Завод имени Мичурина 568 5001 5586 6787 924 7180 4194
Завод Нижне Тувимский Шпалолитейный 4098 9383 1447 9245 9977 8017 5835
Завод 60 летия Ильича 8782 4138 393 9112 2950 9078 9551

Для этого в таблице будет использованы функции «суммесли» и срзначесли».
Для каждого завода запишем формулы:

  • =СУММЕСЛИ($F$1:$V$1; «>=»&B3;F3:V3)

    Суммесли со знаком больше или равно
    Суммесли со знаком больше или равно
  • =СРЗНАЧЕСЛИ($F$1:$V$1; «>=»&B3;F3:V3)
Срзначесли со знаком больше либо равно
Срзначесли со знаком больше либо равно

Обратите внимание что знаки  «<» ; «>» или «<=» должны быть записаны в кавычках и присоединены к адресу ячейки с условием при помощи знака в латинской раскладке «&».

Если необходимо сравнить не с ячейкой, а с заранее известным числом, то функция записывается следующим образом:

=СРЗНАЧЕСЛИ($F$1:$V$1; «>=50»;F3:V3)

Срзначесли и суммесли. Сравнение с числом
Срзначесли и суммесли. Сравнение с числом

Обсудить статью или написать вопросы можно в комментариях или на форуме: Форум по Excel

 

 

 

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *