Найти отличия в двух столбцах таблицы Excel

О том, как найти отличия в двух столбцах «Excel». Совет для начинающих пользователей.

Ранее мы уже рассказывали о том, как найти неверные (ошибочные) значения в столбце таблицы «Excel» при помощи проверки данных. Теперь рассмотрим еще один способ сравнения двух столбцов и нахождения отличий в ячейках этих столбцов.


Сравнение будем производить при помощи функции ВПР().

Эта функция сравнивает ячейки в столбцах вертикально.
Аналогично можно применить функцию ГПР для сравнения значений в строках.
Этот способ, в отличие от ранее описанного, хорош тем, что позволяет отфильтровать (выбрать) неверные данные.

 

Рассмотрим способ нахождения отличий в столбцах подробнее.

  1. Для сравнения данных в эталонном и проверяемым столбцах следует перенести обе таблицы в один документ.
  2. После чего необходимо добавить столбец или выбрать уже существующий в непосредственной близости от проверяемого столбца. В этот столбец запишем функцию ВПР(), которая послужит маркером отличий от эталонного столбца.
  3. Функция выглядит следующим образом:
    =ВПР(B3;A:A;1;0) , где B3- проверяемая ячейка, A:A — диапазон с эталонным  списком, 1 — номер столбца (в данном случае равен «1»), 0- количество допускаемых ошибок в ячейке.Сравнение значений в Excel при помощи ВПР
  4. После того, когда мы протянем функцию по длине проверяемого списка.
  5. Напротив ячеек с отличиями от эталонных значений будут стоять буквы «Н/Д».
  6. Такие ячейки можно отфильтровать стандартным фильтром и обработать отклонения.фильтр ошибочных значений

Этот способ довольно прост и не требует особых навыков владения программой «Excel»

 

 

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *