Форум по Excel

Форум

Добрый день, уважаемый посетитель сайта RuExcel.
Если Вы воспользовались поиском на сайте и не нашли ответа на свой вопрос, можете задать его здесь — на форуме.
Участники форума или администрация сайта с радостью блеснут своей эрудицией и дадут Вам развернутый ответ на поставленный вопрос.
Если вы и сами неплохо ориентируетесь в программе Excel, не ленитесь и подсказывайте новичкам, как решать ту или иную задачу.
Делитесь знаниями и они к Вам обязательно вернутся. 😉
Всем добра и благополучия.

Вы должны войти, чтобы создавать сообщения и темы.

Создание формулы

Добрый день!

Помогите мне пожалуйста с созданием формулы для операций

Есть определенная ячейка, например C8. Нужно, чтобы в ней задавался процент скидки, скидка плавающая, зависит от того какое число получиться, например в ячейке G57

Пример...

от 300 до 599 5%
от 600 до 899 10%
от 900 до 1199 15%
от 1200 до 1499 20%
от 1500 до 1799 25%
от 1800 до 2099 30%
от 2100 до 2399 35%
от 2400 до 2699 40%
от 2700 и выше 45%

Спасибо

 

 

 

=ЕСЛИ(G57<300;0;ЕСЛИ(G57<600;0,05;ЕСЛИ(G57<900;0,1;ЕСЛИ(G57<1200;0,15;ЕСЛИ(G57<1500;0,2;ЕСЛИ(G57<1800;0,25;ЕСЛИ(G57<2100;0,3;ЕСЛИ(G57<2400;0,35;ЕСЛИ(G57<2700;0,4;0,45)))))))))

Спасибо, только выходит сообщение: "не удается ввести указанную формулу, поскольку она использует больше уровней вложенности, чем допускается"

Вероятно у Вас не самая новая версия Excel . Попробуйте разбить на 2 ячейки: 7 уровней вложенности в одной, остальные в другой.

Ячейка 1: =ЕСЛИ(G57<300;0;ЕСЛИ(G57<600;0,05;ЕСЛИ(G57<900;0,1;ЕСЛИ(G57<1200;0,15;ЕСЛИ(G57<1500;0,2;ЕСЛИ(G57<1800;0,25;ЕСЛИ(G57<2100;0,3;B2)))))))

Ячейка B2: =ЕСЛИ(G57<2400;0,35;ЕСЛИ(G57<2700;0,4;0,45))

=ЕСЛИ(G57<300;0;ЕСЛИ(G57<600;0,05;ЕСЛИ(G57<900;0,1;ЕСЛИ(G57<1200;0,15;ЕСЛИ(G57<1500;0,2;ЕСЛИ(G57<1800;0,25;ЕСЛИ(G57<2100;0,3;ЕСЛИ(G57<2400;0,35;ЕСЛИ(G57<2700;0,4;0,45)))))))))

Источник: http://ruexcel.ru/forum/topic/%d1%81%d0%be%d0%b7%d0%b4%d0%b0%d0%bd%d0%b8%d0%b5-%d1%84%d0%be%d1%80%d0%bc%d1%83%d0%bb%d1%8b/#postid-43
© Сайт RuExcel.ru

=ЕСЛИ(G57<300;0;ЕСЛИ(G57<600;0,05;ЕСЛИ(G57<900;0,1;ЕСЛИ(G57<1200;0,15;ЕСЛИ(G57<1500;0,2;ЕСЛИ(G57<1800;0,25;ЕСЛИ(G57<2100;0,3;ЕСЛИ(G57<2400;0,35;ЕСЛИ(G57<2700;0,4;0,45)))))))))

Источник: http://ruexcel.ru/forum/topic/%d1%81%d0%be%d0%b7%d0%b4%d0%b0%d0%bd%d0%b8%d0%b5-%d1%84%d0%be%d1%80%d0%bc%d1%83%d0%bb%d1%8b/#postid-43
© Сайт RuExcel.ru

=ЕСЛИ(G57<300;0;ЕСЛИ(G57<600;0,05;ЕСЛИ(G57<900;0,1;ЕСЛИ(G57<1200;0,15;ЕСЛИ(G57<1500;0,2;ЕСЛИ(G57<1800;0,25;ЕСЛИ(G57<2100;0,3;ЕСЛИ(G57<2400;0,35;ЕСЛИ(G57<2700;0,4;0,45)))))))))

Источник: http://ruexcel.ru/forum/topic/%d1%81%d0%be%d0%b7%d0%b4%d0%b0%d0%bd%d0%b8%d0%b5-%d1%84%d0%be%d1%80%d0%bc%d1%83%d0%bb%d1%8b/#postid-43
© Сайт RuExcel.ru

Добрый день!

Необходима помощь с формулой в макросе:

Есть:

ActiveCell.FormulaR1C1 = _

        "=VLOOKUP(RC1,'[вчера.xlsx]вчера'!R2C1:R16450C50,3,0)"

Нужно

ActiveCell.FormulaR1C1 = _

        "=VLOOKUP(RC1,'[вчера.xlsx]вчера'!R2C1: R «количество строк» C «количество  столбцов»,3,0)"

Попытка:

Dim lLastRow As Long

Dim lLastCol As Integer

lLastRow = Cells(Rows.Count, 1).End(xlUp).Row

  lLastCol = Cells(1, Columns.Count).End(xlToLeft).Column

 

как переменные встроить в формулу с форматом r1c1 ?